RADiCAL’s Motion apps are compatible with: 

  • Apple: requires iOS 11.1 or later.  Compatible with iPhone, iPad, and iPod touch.
  • Android: requires Android 6.0 and up.  

If you run into any trouble on any of your devices, please do shoot us a note at support@getrad.co.  We’re keen to hear from you.